import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(aaa)|(bbb)|(ccc)";
final String string = "aaa\n"
+ "bbb\n"
+ "ccc\n\n"
+ "aaa\n"
+ "bbb\n"
+ "ccc";
final String subst = "\\2\\1\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}