re = /^[A-Za-z]+(?: [A-Za-z]+)* *[ -:] *[A-Za-z]+(?: [A-Za-z]+)*$/m
str = 'Villa-Levski
Villa:Levski
Villa Levski
Villa123-Levski123
Villa123:Levski123
Villa123 Levski123
Villa - Levski
Villa : Levski
Villa Levski
Manchester United - Tottenham HotSpurt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end