package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\w{0,30}){1}(\s?(\w{0,30})){1,4}`)
var str = `fwe foiwje ofi wjeof wwerwer qweqwe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}