// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?isu)[\w]").unwrap();
let string = "ийская, д. 35, кв. 9 Показано с 1 по 1 (Всего: 1) Перейти к разделу Сообщения Включение сведенийё";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}