const regex = /^(?'Username'[-\w\d\.]+?)(?:\s+at\s+|\s+\[at\]\s+|\s*@\s*|\s*(?:[\[\]@]){3}\s*)(?'Domain'[-\w\d\.]*?)\s*(?:dot|\.|(?:[\[\]dot\.]){3,5})\s*(?'TLD'\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'Username\'[-\\w\\d\\.]+?)(?:\\s+at\\s+|\\s+\\[at\\]\\s+|\\s*@\\s*|\\s*(?:[\\[\\]@]){3}\\s*)(?\'Domain\'[-\\w\\d\\.]*?)\\s*(?:dot|\\.|(?:[\\[\\]dot\\.]){3,5})\\s*(?\'TLD\'\\w+)$', 'gm')
const str = `some.email at gmail dot com
asdf-FDSA at ghjkl . net
thomas at yahoo .de
josh@awesomecompanyname dot com
mona.lisa [@] domain [dot] com
stephen.spielberg [@] domain [.] com
lol.dzdz [at] fe dot com
He is not at his best. Lorem Ipsum.
Hit "Perform a substitution" to see some magic happen.`;
const subst = `\1@\2.\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);