re = /^(?:(>.*?$)(.*?)(?=^>|\Z))/m
str = '> header, info, info
TEXT----------------------------------------------------------------
TEXT2-------------------------------------------
>header, info...
TEXT-----------------------------------------------------'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end