import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^STRBI_(\\d{10})_(\\d{8})_(STK|SLS)_(.+)\\.(\\w{3,})$";
final String string = "STRBI_0000010006_20171030_STK_Informe de Stock_20171029.csv\n"
+ "STRBI_0000010007_20171030_STK_Informe de Stock_20171029.csv\n"
+ "STRBI_0000010067_20171030_STK_Informe de Stock_20171009.csv\n"
+ "STRBI_0000010087_20171030_SLS_Informe de Ventas Diarias_20171029.csv\n"
+ "STRBI_0000010087_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv\n"
+ "STRBI_0000010087_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv\n"
+ "STRBI_0000010092_20171030_SLS_Informe de Ventas Diarias_20171029.csv\n"
+ "STRBI_0000010092_20171030_SLS_Informe de Ventas Semanales_20171022 a 20171029.csv\n"
+ "STRBI_0000010092_20171030_SLS_Informe de Ventas_20171009 a 20171109.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}