$re = '/(([A-Za-z]{2})((?=.*[a-z])(?=.*[A-Z])(?=.*\d)[0-9a-zA-Z]{10})\s)/i';
$str = 'Unter anderem sind auch JFgf545344fk zu finden. Aber nicht AZgf54gdfgdfgdg344kjh selle.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);