use strict;
my $str = 'Η σελίδα αυτή είναι απαÏαίτητη για να δημοσιεÏσετε Îνα σχόλιο. Και δεν Îχει οÏτε τώÏα ή Ï€Ïόκειται να θÎλετε να Ïυθμίσετε το παιχνίδι μου πολλά. Στην παÏοχή συμβουλών στους ασθενείς σε όλο τον κόσμο, οι οποίοι είναι διαθÎσιμοι, αλλά Ï€Ïιν ξεκινήσετε
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc vel mi ac neque fringilla egestas ut sit amet felis. In malesuada lacinia ligula, quis tincidunt ante sollicitudin sed.
12351432123213';
my $regex = qr/[a-zA-Z0-9Ά-ωΑ-ώ\s]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}