re = /(([A-Z][a-z]+)\s{0,2}([A-Z][a-z]+)?\s{0,2}([A-Z][a-z]+)?)/
str = 'Russell Lake West'
# Print the match result
str.match(re) do |match|
puts match.to_s
end