using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a class=""link"" href=""([^""]+)"">([^<]+)<";
string input = @"<a class=""link"" href=""pagedetail.html?record_id=123456"">RecordName</a>
<a class=""link"" href=""pagedetail.html?record_id=789012"">RecordName2</a>
<a class=""link"" href=""pagedetail.html?record_id=111111"">RecordName3</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}