re = /<a class="link" href="([^"]+)">([^<]+)</
str = '<a class="link" href="pagedetail.html?record_id=123456">RecordName</a>
<a class="link" href="pagedetail.html?record_id=789012">RecordName2</a>
<a class="link" href="pagedetail.html?record_id=111111">RecordName3</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end