re = /(?<!\*)\*\*([^*\\\n]*(?:\\.[^*\\\n]*)*)\*\*(?!\*)/m
str = '**abc*def***
**abc*def**
**abc\\*def\\***
**abc def**'
subst = '*\\1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result