# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\*)((?:\*\*)*)\*\*([^*\\\n]*(?:\\.[^*\\\n]*)*)\*\*((?:\*\*)*)(?!\*)/\1*\2*\3/gm;t' <<< "**abc*def***
**abc*def**
**abc\*def\***
**abc def**
**hello \* world**"