use strict;
my $str = '**abc*def***
**abc*def**
**abc\\*def\\***
**abc def**
**hello \\* world**';
my $regex = qr/(?<!\*)((?:\*\*)*)\*\*([^*\\\n]*(?:\\.[^*\\\n]*)*)\*\*((?:\*\*)*)(?!\*)/mp;
my $subst = '\\1*\\2*\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";