package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z áéíóúÁÉÍÓÚñÑ@&._$-]+`)
var str = `jhongranados@gmail.com
hola@gmail.com
buenas.com
@julio.com
123hhs@
1jh.com
1jh@s.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}