# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*ga\/([^\/$]*)\${4}.*/\1/gm;t' <<< "gs://analytics_models_from_g_rdd_ga/9g653798d-7e13-4238-55443-6db72ace9911$$$$events_today.csv"