using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*ga/([^/$]*)\${4}.*";
string substitution = @"\1";
string input = @"gs://analytics_models_from_g_rdd_ga/9g653798d-7e13-4238-55443-6db72ace9911$$$$events_today.csv";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}