re = /.*ga\/([^\/$]*)\${4}.*/m
str = 'gs://analytics_models_from_g_rdd_ga/9g653798d-7e13-4238-55443-6db72ace9911$$$$events_today.csv'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result