package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<TAC>.*)[0-9]{6}`)
var str = `01473400153184`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}