#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Main:\s*\w*\(\s*\)\s*\{ <--[^}]*(?:\}(?! <--)[^}]*)*\} <--$"
Local $sString = "Main: Subroutine( )" & @CRLF & _
"{ <--" & @CRLF & _
" Include(foo = bar )" & @CRLF & _
" Call(foo = bar )" & @CRLF & _
" Repeat(foo = ibar )" & @CRLF & _
" {" & @CRLF & _
" Message("Message = bar number {ibar}" foo )" & @CRLF & _
" Something( )" & @CRLF & _
" Message("Message = foo {bar}" )" & @CRLF & _
" }" & @CRLF & _
" Message("Message = again {iterations}" )" & @CRLF & _
" For(start = foo , end = bar )" & @CRLF & _
" {" & @CRLF & _
" Comment( )" & @CRLF & _
" }" & @CRLF & _
" While(foo )" & @CRLF & _
" {" & @CRLF & _
" Comment( )" & @CRLF & _
" }" & @CRLF & _
" Comment( )" & @CRLF & _
"} <--"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")