$re = '/(?: # group, but do not capture:
foo # \'foo\'
| # OR
bar # \'bar\'
| # OR
baz # \'baz\'
) # end of grouping
(?= # look ahead to see if there is:
quz # \'quz\'
) # end of look-ahead/x';
$str = 'fooquz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);