$re = '/^[+-]?[1-9][0-9]*$/m';
$str = '-90
90
-0
-00
1
-1
0
00
+2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);