import Foundation
let pattern = ##"\b(#?[0-9]{4})"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
.discrim #3333
.discrim 3333
.discrim 3333#
.discrim 3#333
.discrim #33333
.discrim #49275555
.discrim 37583875
.discrim #%$%f334f34f5545 5555
.discrim #5434foijofesrjg gjfi
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)