#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?:\.\d+)?[<>-]+(\d+(?:\.\d+)?).*"
Local $sString = "7.20-<7.35" & @CRLF & _
"25-<32" & @CRLF & _
"60-<83e" & @CRLF & _
"40-<50" & @CRLF & _
"0.85-<1.15" & @CRLF & _
"80-<98" & @CRLF & _
"3.0-<3.4" & @CRLF & _
"NA" & @CRLF & _
"3.0-<3.4 (110)" & @CRLF & _
"0.85-1.15" & @CRLF & _
"0.85>1.15" & @CRLF & _
"0.85->1.15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")