import Foundation
let pattern = #"(?<!\d)(\d)(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"128.32.1.1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)