$re = '/<Account Id=".*">/m';
$str = '<Account Id=">
<Account Id="">
<Account Id=""">
<Account Id="123456789012">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);