$re = '/t\([",\'].+[",\']\);/i';
$str = 't(\'ciao\');
t("asd");
t("asd".$qualsiasicosa."asd");
t(\'ciao\'.$qualsiasicosa.\'ciao\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);