$re = '/(?: |\G)\d\B\K/';
$str = '123 a123 1234567 b123';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;