package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^"'(])*?3.png([^"')]*)`)
var str = `<img src="images/3.png" alt="" width="19" style="font-family:Arial,Helvetica,sans-serif;font-size:13px;line-height:13px;display:block;border:none" class="t_w100p m_w100p" />
<img src="3.png" alt="" width="19" style="font-family:Arial,Helvetica,sans-serif;font-size:13px;line-height:13px;display:block;border:none" class="t_w100p m_w100p" />
<img src="13.png" alt="" width="19" style="font-family:Arial,Helvetica,sans-serif;font-size:13px;line-height:13px;display:block;border:none" class="t_w100p m_w100p" />
<img src="images/13.png" alt="" width="19" style="font-family:Arial,Helvetica,sans-serif;font-size:13px;line-height:13px;display:block;border:none" class="t_w100p m_w100p" />
<style> ul { background: url('images/3.png') }</style>
<style> ul { background: url('3.png') }</style>
<style> ul { background: url('images/13.png') }</style>
<style> ul { background: url('13.png') }</style>
<style> ul { background: url(images/13.png) }</style>
<style> ul { background: url(13.png) }</style>
<style> ul { background: url(images/3.png) }</style>
<style> ul { background: url(3.png) }</style>`
var substitution = "https://stackoverflow.com"
fmt.Println(re.ReplaceAllString(str, substitution))
}