package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bSFP-[0-9]{5}\b`)
var str = `1fb99f55 SFP-24576: If Fulfiller gwVersion=4.0, then do not convert order to v3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}