using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<="")(?i:p).*\.txt(?="")";
string input = @"string myString = ""P671221.txt"";
Regex reg = new Regex(""P*.txt""); //<--- what goes here?
if (reg.IsMatch(myString)
{
Console.WriteLine(""Match!""));
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}