re = /(?<=")(?i:p).*\.txt(?=")/
str = 'string myString = "P671221.txt";
Regex reg = new Regex("P*.txt"); //<--- what goes here?
if (reg.IsMatch(myString)
{
Console.WriteLine("Match!"));
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end