import re
regex = re.compile((r"^( *)( *)( *)(['.-])((?!\4)(?4)+?)((?!\4|\5)(?4)++)\1\3whale\n"
r"(?=.(.))\6.\7\4(?!\4|\6)([_\/])\3(?!(?11))\8\2(?=\2)\3\1_((?=\4+.).\5(?!\6)\5)(?!.?')\7\4\n"
r"(?=.\7)\6.([,`])\3{2}(?=.((?!\8)[_\/])\11)\Q(_\E.\4{2}(?!\.)\5((?!\10)(?10)(?!\4+|\5|\6))\1\3{3}(\\)\n"
r"(\3{3})\13\2{2}\1{1}\3+(?<=\S {10})\4\1\3\|\n"
r"\1(?=\12)(?12)(?!`,)\10\4(\11{2})\4\14\10\15\9\8\n"
r"\14{2}(?=\6)['-]\4(?<!-)\11\8\11\4\6\11\15\.-|(?!)"))
test_str = (" .'- whale\n"
"-::./ / _.'':.\n"
"-:, (__..'` \\\n"
" \\ . |\n"
"`,.__. ,__.''/\n"
" -._/_.-___.-")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")