#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https?://(?:www\.|)([\w.-]+).*"
Local $sString = "https://domen.site.ru/podsait/03285926/#2412747495" & @CRLF & _
"http://www.site.ru/site/24722305" & @CRLF & _
"https://www.domen.site.ru/site/247493215/site" & @CRLF & _
"site.ru"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)