package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://(?:www\.|)([\w.-]+).*`)
var str = `https://domen.site.ru/podsait/03285926/#2412747495
http://www.site.ru/site/24722305
https://www.domen.site.ru/site/247493215/site
site.ru`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}