#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-\w ]+(,[-\w ]+)+$"
Local $sString = "" & @CRLF & _
"1000,two thousand,3000" & @CRLF & _
"1000 , 2000 , 3000" & @CRLF & _
"First Option,2Nd Option, THIRD Option" & @CRLF & _
"" & @CRLF & _
"Single Value" & @CRLF & _
"1000 ,, 2000 , 3000" & @CRLF & _
"1000 , 2000 , 3000," & @CRLF & _
"1000 , 2000 , 3000,," & @CRLF & _
",,1000 , 2000 , 3000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")