import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)\\. ?(.+?)(?:value|vlaue|balue|valie): ?(.+?)[\\n\\r]{2,}";
final String string = "Some junk data\n"
+ "More junk data \n\n"
+ "1. fairly long key, all on one line\n"
+ "value: some other text with spaces and stuff\n\n"
+ "Some junk data\n\n"
+ "More junk data \n\n"
+ "2. hey look! another long \n"
+ "and broken key. on two lines\n"
+ "value: a different value with some different information\n\n"
+ "Some junk data\n"
+ "More junk data \n\n"
+ "3. hey look! another long line. on a line\n"
+ "value: a different value \n"
+ "broken, with some different information\n\n"
+ "Some junk data\n"
+ "More junk data ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}