const regex = /([()-]|\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([()-]|\\d+)', '')
const str = `(123-456)-12-1`;
const subst = `hit!`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);