#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<strong>.*?<\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b"
Local $sString = "The man drove in his car.Then <strong>the man walked to the boat.</strong>"
Local $sSubst = "gokart"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)