$re = '/<strong>.*?<\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b/i';
$str = 'The man drove in his car.Then <strong>the man walked to the boat.</strong>';
$subst = "gokart";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;