re = /<strong>.*?<\/strong>(*SKIP)(*FAIL)|\b(boat|car)\b/i
str = 'The man drove in his car.Then <strong>the man walked to the boat.</strong>'
subst = 'gokart'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result