re = /\b(?:more|most)\s+\w*ly(*SKIP)(*F)|\w*ly/m
str = 'fastly onffly fly incomprehensibly totaly happily
lily sly more happily
most seriously'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end