const regex = /<td(.+|)(class="myClass")(.+|)>(.+)<\/td>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td(.+|)(class="myClass")(.+|)>(.+)<\\\/td>', 'g')
const str = `<td>I Dont want this</td>
<td class="myClass">I want this</td>
<td class="myClass" id="myID">I want this</td>
<td style="border-top-width: 0px; class="myClass">I want this</td>
<td class="niggaWhat" yoh how are you>as long as</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}