package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([01][0-9]|2[0-3]):[0-5][0-9]
`)
var str = `20:59
00:59
01:01
10:30
00:00
24:59
30:01
00:60
05:122
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}