import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([01][0-9]|2[0-3]):[0-5][0-9]\n";
final String string = "20:59\n"
+ "00:59\n"
+ "01:01\n"
+ "10:30\n"
+ "00:00\n\n"
+ "24:59\n"
+ "30:01\n"
+ "00:60\n"
+ "05:122\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}