Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([01][0-9]|2[0-3]):[0-5][0-9]
/
gmi
Test String
New
20:59 00:59 01:01 10:30 00:00 24:59 30:01 00:60 05:122