using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"πc=(?<MyFileName>[^&]*)";
string input = @"...........πc=pic%231.pdf&description=.......
...........πc=pic.pdf&description=.......
...........πc=pic%232.pdf&description=.......
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}