import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "πc=(?<MyFileName>[^&]*)";
final String string = "...........πc=pic%231.pdf&description=.......\n"
+ "...........πc=pic.pdf&description=.......\n"
+ "...........πc=pic%232.pdf&description=.......\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}