$re = '/^[?:!.,;\'\"«»]+|[?:!.,;\'\"«»]+$/m';
$str = '«Be!!»
"Here!!!"
«I';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;